Solution: Lemur daemon not connecting to midi ports

Discuss problems and solutions.

Solution: Lemur daemon not connecting to midi ports

Postby stutter » 01 Nov 2017 18:45

Prompted by the recent update, I tested lemur again to see if I could resolve a problem that has prevented me from using lemur recently, and I have a solution. Posting here in case it is useful for others...
The issue below began possibly after a Windows update and has remained unresolved for months despite testing everything I could find. Have seen similar descriptions of problem on web. Contacted Liine support but no answer.
I seem to have fixed it.

lemur cannot connect to virtual midi ports.
The virtual ports remain red in the lemur daemon when selected.
Lemur editor will communicate with lemur
OSC will communicate.
(Note: lemur daemon uses different port than editor or OSC - see here)
Tested UDP port of lemur daemon without success.
Checked firewall rules without success
Disabled firewall - without success
Tested virtual midi ports - work with other software
Tried different virtual midi ports - no success
Tested different network - via router and via direct wifi connection to computer (ad-hoc network or wireless access point) - no success

It seems the issue is related to the lemur daemon software - all other parts of the chain otherwise seem to work. I guess there is some peculiar issue between Windows and the daemon on this computer that I cannot identify. I had given up, since contacting support in the hopes they could provide an alternate version or at least one that logged errors was unsuccessful.
Lemur also communicates with the lemur daemon and virtual midi ports on another computer on the same network.

I was hoping that an updated lemur daemon would resolve the issue, but it does not.

Using Studiomux(free midimux version should work), I can set up 8 midi in and 8 midi out ports which the lemur app can see and connect to, and also offers wired connection (I think lemur offers this, been so long not working as to not remember if it was available on Windows or just on Mac). In effect it can be used to replace the lemur daemon - you have to run another app on the ipad, but you get the additional benefits of that app.

If anybody thinks this is the same problem that they have, and require screenshots to demonstrate, reply and I will post pics/guide.

Delighted that I can use lemur again. Liine support leaves a bit to be desired.

My spec:
Lemur 5.3.4 (but problem also on 5.3.3)
Windows 10 (version 1703)
loopMidi v.1.0.13 (24) (i.e. latest version - available here - also tested copperlan and loopbe)

Weirdly using much the same setup on a laptop and desktop, and the laptop works fine while the desktop does not.
Posts: 2
Joined: 21 Nov 2016 20:26

Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 4 guests