Newbie question: how to convert this time based script

Discuss Lemur and share techniques.

Newbie question: how to convert this time based script

Postby mbirame » 07 May 2017 17:13

Hi folks,
I am creating a quad LFO with a multiball. It is working great using the time variable and the example from the manual. For each multiball I am using something like this:
MultiBall.x[0] = sin(time * 1) *0.5 + 0.5;

i have that script being executed "on frame".

I would like to replace the "time" variable so that the LFO is being clocked to an incoming MIDI clock signal....but I don't know how to do that. Can anyone show me how to change the equation to work? I'm using an Expert Sleepers FH-1 to send a cv pulse into that module and that is sending a clock pulse into the lemur.

I tried to set up a monitor with midi_clocks[0] but nothing but a 0 is being displayed....
mbirame
Newbie
 
Posts: 8
Joined: 12 Apr 2017 22:05

Re: Newbie question: how to convert this time based script

Postby mbirame » 10 May 2017 00:46

Well I sort of figured this out. The problem is that I find Midi_clocks to be very inconsistent. I don't know if the problem is with Lemur, the FH-1, or with the MIDI Daemon/iPad, etc. Lemur is very inonsistent about which port is displayed from which part of the vector of midi_clocks. Sometimes, one port comes out of 0 sometimes out of 1, etc, etc. It's hard to debug things when things are inconsistent and there seem to be a lot of variables (and very little support),
mbirame
Newbie
 
Posts: 8
Joined: 12 Apr 2017 22:05

Re: Newbie question: how to convert this time based script

Postby nick_liine » 18 May 2017 12:28

mbirame wrote:Well I sort of figured this out. The problem is that I find Midi_clocks to be very inconsistent. I don't know if the problem is with Lemur, the FH-1, or with the MIDI Daemon/iPad, etc. Lemur is very inonsistent about which port is displayed from which part of the vector of midi_clocks. Sometimes, one port comes out of 0 sometimes out of 1, etc, etc. It's hard to debug things when things are inconsistent and there seem to be a lot of variables (and very little support),


Could you please send an email to support@liine.net regarding this issue? I don't understand what you mean about "one port comes out of 0 sometimes out of 1, etc". Do you mean that midi_clocks are mismatched with regards to the MIDI Targets?
nick_liine
Liine Staff
 
Posts: 457
Joined: 01 Oct 2010 11:06


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 4 guests

cron